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It’s our pleasure to be part of the eighth edition of 
 Using SPSS for Windows and Macintosh: Analyzing and 
Understanding Data. Our objective has been to make each 

revision of our book more accessible and readable, so that 
readers can properly conduct statistical analyses with SPSS 
and make appropriate interpretations of the obtained results.

The development of easy-to-use statistical software like 
SPSS has changed the way statistics is being taught and 
learned. No longer do students have to learn a system of 
elaborate code to conduct simple or complex analyses. 
Instead, students simply enter their data into the easy-
to-use Data Editor. They can then select items from a 
drop-down menu to make appropriate transformations of 
variables, click options from another menu to create graphs 
of distributions of variables, select among various statisti-
cal analyses by clicking on appropriate options, and more. 
With a minimal amount of time and effort, the output is 
displayed, showing the results.

Researchers also have benefited from applications like 
SPSS. They do not have to spend time reacquainting them-
selves with the ins and outs of a statistical software package 
or learning new programs for conducting analyses that take 
hours to master. They also do not have to teach assistants 
how to write code to produce analyses, or examine and reex-
amine code that has produced error messages that do not 
really indicate what is wrong. Everyone can just point and 
click. More sophisticated users can use the syntax features.

In general, programs like SPSS have made life easier 
for students who are learning statistics, for teachers who 
are teaching statistics, and for researchers who are applying 
statistics. Nevertheless, many users of these programs find 
“doing statistics” an arduous, unenjoyable task. They still 
are faced with many potential obstacles, and they feel over-
whelmed and stressed rather than challenged and excited 
about the potential for mastering these important skills.

What are some of the obstacles that students, in particu-
lar, face when they are trying to conduct statistical analyses 
with SPSS?

•	 Obstacle 1: Although SPSS is easy to use, many  students 
and first-time users find it very complex. They have 
to learn how to input data into the Data Editor, save 
and retrieve data, make transformations to data, con-
duct analyses, manipulate output, create graphs, edit 
graphs, and so on.

•	 Obstacle 2: Students can feel helpless. Although they 
know how to point and click, they are frequently con-
fronted with new dialog boxes with many decisions to 
make. Their instructor does not have the time to talk 

about each of the options, so students feel as if they are 
making uninformed decisions.

•	 Obstacle 3: The amount of output and numbers pro-
duced by any statistical procedure is enough to cower 
most researchers if they are forced to explain their 
meaning. How can students who are taking statistics 
for the first time feel confident about interpreting out-
put from an SPSS procedure? In trying to understand 
output, they are likely to face language problems. For 
example, “What is a significant F value? Is it the same 
as the p value that the instructor is talking about? No, it 
couldn’t be, or she or he would have told us.”

Researchers, graduate students, and more advanced 
undergraduate students are going to face additional 
obstacles.

•	 Obstacle 4: Users can think of a number of different 
ways to analyze their data, but they are unsure about 
which way would yield the most understanding of 
their results and not violate the assumptions underly-
ing the analyses.

•	 Obstacle 5: Even if users make all good decisions about 
statistical approaches and understand the output, they 
still must write a Results section that conforms to the 
American Psychological Association (APA) format.

Using SPSS for Windows and Macintosh: Analyzing and 
Understanding Data for Version 23 of SPSS helps readers 
overcome all of the obstacles discussed earlier.

The book is divided into 10 units, which are as follows:
Units 1 to 4 guide students through the most basic of 

SPSS techniques and use a step-by-step description to mas-
ter such techniques.

Unit 1, “Getting Started with SPSS,” shows the student 
how to get started using SPSS, including a survey of the 
main menus, a description of how to use SPSS Help, and a 
brief tour of what SPSS can do.

Unit 2, “Creating and Working with Data Files,” goes 
through the steps of defining variables, showing how data 
are entered and edited, how to use the Data Editor and the 
data view screens, how to print SPSS data files, and how to 
import and export information to and from SPSS.

Unit 3, “Working with Data,” describes how to find 
and replace data, recode and compute values, sort data, 
and merge and split files.

Unit 4, “Working with SPSS Graphs and Output for 
Windows,” teaches the student how to create and enhance 
SPSS charts as well as how to work with SPSS out-
put including pivot tables. SPSS Windows (version 23)  
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and Macintosh (version 23) differ in the way that graphics 
are created and edited, and, thus, there is a separate sec-
tion covering each—Lesson 16A for Windows and Lesson 
16B for the Macintosh. SPSS is becoming increasingly 
cross-platform, and if you know the Windows version, you 
can easily adapt to the Macintosh version (and vice versa).

Each unit from 5 through 10 presents a set of statis-
tical techniques and a step-by-step description of how 
to conduct the statistical analyses. This is not, however, 
a “cookbook” format. We provide extensive substantive 
information about each statistical technique, including a 
brief discussion of the statistical technique under consider-
ation, examples of how the statistic is applied, the assump-
tions underlying the statistic, a description of the effect size 
for the statistic, a sample data set that can be analyzed with 
the statistic, the research question associated with the data 
set, step-by-step instructions for how to complete the anal-
ysis using the sample data set, a discussion of the results 
of the analysis, a visual display of the results using SPSS 
graphic options, a Results section describing the results in 
APA format, alternative analytical techniques (when avail-
able), and practice exercises.

Unit 5, “Creating Variables and Computing Descriptive 
Statistics,” shows how to create new variables from existing 
ones and discusses the basic procedures for describing 
qualitative and quantitative variables.

Unit 6, “t Test Procedures,” focuses on comparing 
means and shows how to use a variety of techniques, 
including independent and dependent t tests and the one-
sample t test.

Unit 7, “Univariate and Multivariate Analysis-of-
Variance Techniques,” focuses on the family of analysis-
of-variance techniques, including one-way and two-way 
analyses of variance, analysis of covariance, and multivari-
ate analysis of variance.

Unit 8, “Correlation, Regression, and Discriminant 
Analysis Procedures,” includes simple techniques such as 
bivariate correlational analysis and bivariate regression 
analysis, as well as more complex analyses such as partial 
correlational analysis, multiple linear regression, and dis-
criminant analysis.

Unit 9, “Scaling Procedures,” focuses on factor analy-
sis, reliability estimation, and item analysis.

Unit 10, “Nonparametric Procedures,” discusses a 
variety of nonparametric techniques, including such tests 
as the binomial, one-sample chi-square, Kruskal-Wallis, 
McNemar, Friedman, and Cochran tests.

New to This Edition
Version 23 of SPSS for Windows and the Macintosh offers 
additional features of great value. For more details about 
these features, refer to the SPSS Web site http://www-01 
.ibm.com/common/ssi/cgi-bin/ssialias?infotype%3DPM
%26subtype%3DSP%26htmlfid%3DYTD03023USEN.

This eighth edition of Using SPSS for Windows and 
Macintosh includes the following changes:

•	 Revisions to instructions have been made to ensure 
they are consistent with the latest version of SPSS.

•	 New exercises have been added to the end of lessons.

•	 Revisions to statistical information have been made to 
make it more accessible to readers.
Also, please note the following:

•	 While this edition of Using SPSS for Windows and 
Macintosh focuses on version 23, the material within the 
chapters is directly applicable to other versions of SPSS 
as well. In other words, version 23 is backward compat-
ible with most earlier versions of SPSS. While there may 
be some slight differences, and earlier  versions offer 
fewer features, the user should have no difficulty adapt-
ing these materials to the version he or she has available.

Please note that SPSS is developed and owned by 
IBM and is formally referred to as IBM SPSS Statistics.

Online Data Files
All the data files that you will need to work through the les-
sons in Using SPSS for Windows and Macintosh are available 
on the Web through the instructor. You can request your 
instructors for the same who can download and distribute 
the data files from the Pearson’s website at  http://www.
pearsonhighered.com. Several data sets—particularly, Crab 
Scale Results and Teacher Scale Results—will be intro-
duced as you work through the first 18 lessons. A detailed 
description of these two files is provided in Appendix A.

There are two more types of data sets used in the later 
units. The first are data files that may be used when learn-
ing particular SPSS procedures, such as paired-samples, 
t test, or factor analysis. Any of these files can be easily 
identified since they are named, for example, Lesson 23 Data 
File 1 or Lesson 36 Data File 1. Also used in the second half 
of the book are data files for completing exercises at the end 
of lessons. These are named, for example, Lesson 23 Exercise 
File 1 or Lesson 36 Exercise File 2.

Please note that the Web site does not contain any execut-
able SPSS data files. You need to have access to SPSS to use 
these files, as most users of this book will, at the school, com-
pany, or other institution. SPSS (at http://www.ibm.com 
/analytics/us/en/technology/spss/) offers a wide price 
range packages, including those for students.

Other Features of The Book
LEARNING OBJECTIVES At the beginning of each unit, 
you will see a list of objectives—skills that you will master 
when you successfully complete the content of the lesson 
and work through all of the exercises in the lesson. These 
advanced objectives indicate what you can expect, and 
what is expected of you.
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TyPING CONVENTIONS There is only one typing con-
vention you must attend to throughout this book. A sequence 
of actions is represented by what options are selected from 
what menu, connected by an arrow like this S.

For example, if a certain procedure requires clicking on 
the File menu and then clicking the New option, it would 
be represented as follows.

1. Click File S New.

ExAMPLES Each lesson includes step-by-step procedures, 
with copious illustrations of screen shots, for successfully 
completing a technique with sample data. Exercises at the end 
of each lesson allow you to practice what you have learned.

TIPS Some of the lessons contain tips (in the margins) that 
will help you learn SPSS and will teach you shortcuts that 
make SPSS easier to use.

System Requirements for SPSS 23  
for Windows
If you are using SPSS 23 for Windows, then your system 
must meet the following minimal requirements:

•	 Microsoft Windows, Windows 7, and Windows 8 and 
10 (plus Windows Server)

•	 Intel or AMD processor running at 1 gigahertz (GHz) 
or higher.

•	 4 gigabytes (GB) of RAM or more.

•	 2 gigabytes of available hard-disk space. If you install 
more than one help language, each additional language 
requires 60–70 MB of disk space.

•	 DVD/CD drive (unless downloaded online).

•	 1024 * 768 or a higher-resolution monitor.

System Requirements for SPSS 23  
for Mac OS X
If you are using SPSS 23 for Macintosh, then your system 
must meet the following minimal requirements:

•	 Mac OS® X 10.10 or higher (Yosemite).

•	 Intel processor.

•	 4 gigabytes (GB) of RAM or more.

•	 2 gigabytes of available hard-disk space. If you install 
more than one help language, each additional language 
requires 60–70 MB of disk space.

•	 DVD/CD drive.

•	 1024 * 768 or a higher-resolution monitor.

Version 23 for both Windows and the Macintosh are 
virtually identical. The same differences in keystrokes that 
apply between the operating systems also apply for the use 
of SPSS. For example, to select all the files listed in a dialog 
box in the Mac version, use the Command (also known as 
the Apple key) + A key combination. For Windows, it’s the 
CTRL+A key combination.
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No book is ever the work of only the authors. 
 Using SPSS for Windows and Macintosh was first 
contracted with Chris Cardone, whom we would 

like to thank for giving us the opportunity to under-
take the project. Chris remains a good colleague and a 
better friend.

We would like to thank the many instructors and 
students who have contacted us about the book. We have 
very much appreciated your positive comments and your 
 constructive suggestions. 

Thank you for using this book. We hope it makes 
your SPSS activities easy to learn, fun to use, and helpful. 
Should you have any comments about the book (good, 
bad, or otherwise), feel free to contact us at the e-mail 
addresses listed below.

Samuel B. Green
samgreen@asu.edu

Neil J. Salkind
njs@ku.edu
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Unit 1

Getting Started with SPSS

 Outline

You’re probably familiar with how other personal 
 computer applications work, and you will find that 
many SPSS features operate exactly the same way. 
You probably already know about dragging, clicking, 
double- clicking, and working with files. If you don’t, 
you can refer to one of the many basic operating systems 
books available for Windows or the Macintosh operat-
ing  systems. We assume that you are familiar with basic 
operating systems skills, such as clicking with a mouse, 
dragging objects, naming and copying files, printing 
documents, and the everyday tasks associated with 
 using a personal  computer.

In this first unit, we introduce you to SPSS, begin-
ning with how to start SPSS, and walk you through a tour 
so  that you know some of the most important features 
of SPSS.

In Lesson 1, “Starting SPSS,” the first of four lessons in 
this unit, you will find out how the SPSS Windows group is 
organized and how you start SPSS.

In Lesson 2, “The SPSS Main Menus and Toolbar,” we 
introduce you to the opening SPSS window, point out the 
various elements in the window, and explain what they do. 
The main menus in the SPSS window are your opening to 
all the SPSS features you will learn about in Using SPSS for 
Windows and the Macintosh. We also introduce you to the 
toolbar, a collection of icons that perform important tasks 
with a click of the mouse.

Lesson 3, “Using SPSS Help,” introduces you to SPSS 
online help. If you’ve ever used another Windows applica-
tion, you know how handy it is to have this type of help 
immediately available and how it can get you through 
even the most difficult procedures.

In Lesson 4, “A Brief SPSS Tour,” we provide a simple 
example of what SPSS can do, including simple analysis, the 
use of Data View and Variable View, and the creation of a 
chart. Here we’ll whet your appetite for the terrific power 
and features of SPSS and what is in store for you throughout 
the book.

Lesson 1: Starting SPSS
•	 The SPSS Opening Window

Lesson 2: The SPSS Main Menus and Toolbar 
•	 The SPSS Main Menus
•	 The Data Files

Lesson 3: Using SPSS Help
•	 How to Get Help
•	 Using Contents

Lesson 4: A Brief SPSS Tour
•	 Opening a File
•	 Working with Appearance
•	 Creating a New Variable
•	 A Simple Table
•	 A Simple Analysis

 Learning Objectives

Lesson 1: Identify the steps of using SPSS with 
respect to Windows and Mac applications

Lesson 2: Describe the features and functions 
of the SPSS menu and its toolbar

Lesson 3: Outline the usefulness of the  SPSS 
online help 

Lesson 4: Recall how to utilize the analytic  
procedures of the SPSS

1



Lesson 1: Starting SPSS
Lesson 1  Identify the steps of using SPSS with respect 

to Windows and Mac applications.

With this lesson, you will start your journey on learning how 
to use SPSS, a powerful and easy to use data analysis package.

Keep in mind that throughout these lessons we expect 
you to work along with us. It’s only through hands-on 
 experiences that you will master the basic and advanced 
features of this program.

SPSS is started by clicking the icon  (or, the name rep-
resenting the program) that represents the application on 
your Windows or Macintosh desktop. You can also access 
the SPSS icon through whatever file access tool you regularly 
use. Finally, you can always click on any already existing 
SPSS file to open the application (and, of course, that file).

The file that executes SPSS may be located in a variety 
of places on your computer, depending upon how it was 
installed. If you are working off a server (e.g., at a college 
or university), you may have to ask for some assistance if 
the SPSS icon is not readily visible.

Tip
As SpSS has evolved over 23 versions, new features 

have been added along the way and most important, 

the various versions (Windows, Macintosh, and Linux) 

have become increasingly similar in their look, feel, 

and functionality. Such is the case now where version 

23 for Windows and the Macintosh are almost identi-

cal in their performance and if you use one version, you 

should be able to use the other. Because there is such 

a large proportion of SpSS users who use the Windows 

version (although the Mac portion is increasing), Using 

SPSS will provide examples from the  Windows version. 

However, in these first few lessons, we will provide some 

Mac screens so you can see the high degree of similarity 

between versions.

Figure 1.1. The iBM® SpSS® Statistics software (“SpSS”) for Windows opening Screen.

SpSS inc. was acquired by iBM in October, 2009.

1.1: The SPSS Opening Window
As you can see in Figures 1.1 and 1.2, the opening 
screen for Windows and the Macintosh versions of SPSS 

2 Unit 1

presents a series of options that allow you to select from 
running the SPSS tutorial, typing in data, posing an exist-
ing query, or creating a new query. The opening screens 
for the Windows and the Mac applications are virtually 
identical.

Figure 1.2 shows the highly similar opening screen for 
the Macintosh version.
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Figure 1.2. The SpSS for the Macintosh opening screen.

On either platform, you can do the following:

•	 Create a new file or a database query,

•	 Open a file that you have recently worked with,

•	 Review some of the new features offered by SPSS 23,

•	 Learn about the different modules that SPSS 23 
offers,

•	 Use the SPSS Tutorial feature, and

•	 Move immediately to the use of several SPSS 
features.

Should you not want to see this screen each time 
you open SPSS, then click on the “Don’t show this dia-
log in the future” box in the lower left corner of the 
window.

For our purposes, we will click the Using the Data 
Editor option (and then click OK) since it is likely to be 
the one you first select upon opening and learning SPSS. 
Once you do this, the Variable View window you see in 
Figure 1.3 becomes active. This is where you enter the 
names of the variables you want to work with and de-
scribe their parameters or characteristics.

Although you cannot see it when SPSS first opens, 
there is another open (but not active) window as well. This 
is the Data View where the actual data for the analysis 
will be entered. This is where you enter data you want to 
use with SPSS once that data have been defined. You can 
switch between the Variable and the Data views by click-
ing on the tab named as such. We will cover both views in 
Lesson 5 (Unit 2).

The Viewer displays the results of statistical analy-
sis and charts that you create. An example of the Viewer 
window is shown in Figure 1.4 where the results of a 
very simple (descriptive) analysis are shown. A data set 
is created in the Data Editor, and once the set is analyzed 
or graphed, you examine the results of the analysis in 
the Viewer.

If you think the Data Editor is similar to a spreadsheet 
in form and function, you are right. In form, it certainly 
is, since the Data Editor consists of rows and columns just 
like offered, for example, by Excel and Open Office. Values 
can be entered and then manipulated. In function as well, 
the Data Editor is much like a spreadsheet. Values that are 
entered can be transformed, sorted, rearranged, and more. 



Figure 1.3. The SpSS Variable View window.

Figure 1.4. The Viewer.
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Lesson 2: The SPSS Main 
Menus and Toolbar
Lesson 2  Describe the features and functions of the 

SPSS menu and its toolbar.

Menus are the key to operating any Windows or Mac 
 application, and that is certainly the case with SPSS. Its 
main menus include Help menus for the Windows  version 
(11 menus) and the 11 main menus for the Mac version. They 
provide access to every tool and feature that SPSS has to offer.

In this lesson, we will review the contents of each of 
these menus and introduce you to the toolbar, a set of icons 
that takes the place of menu commands. The icons make it 
quick and easy to do anything, from saving a file to print-
ing a chart.

2.1: The SPSS Main Menus
SPSS comes to you with 11 main menus, as you can see in the 
opening screen in Figure 2.1. Although you think you may 
know all about the File menu and what options are available 
on it, stick with us through the rest of this lesson to see exactly 
what the File menu, and the other ten menus, can do for you.

Tip
To place SpSS on the desktop, open the File Explorer 

in Windows (in this case, version 10), locate the SpSS 

executive file (spss.exe), and drag it on to the desktop or 

right-click and pin it to the taskbar. To place it on the Mac 

desktop, just locate it on the hard drive (in the Applications 

folder) and drag it on to the desktop or to the Dock.

In addition, SPSS can use formulas to compute new vari-
ables and values from existing ones, as you will learn in 
Lesson 12 (Unit 3).

Also, as you will learn in Lesson 10 (Unit 2), one of 
the many conveniences of SPSS is its ability to import 
data from a spreadsheet accurately and efficiently. This 
ability makes SPSS particularly well suited and pow-
erful for further analysis of data already available in 
spreadsheet form.

Exercises: Lesson 1
 1.  What are some of the purposes to which you think 

SPSS can be best used? Use examples from your 
own field of study.

2.  Talk with a faculty member or a colleague who uses 
SPSS and ask him or her how this tool is used and 

how it helps them better understand their area  
of study.

3.  Why do you think that SPSS may be superior to a 
spreadsheet for the recording and analysis of data?

Figure 2.1. The SpSS main menus.

Tip
When items on a menu appear dimmed, it means they are 

not available.

ThE FILE anD EDIT MEnUS The purpose of the File 
menu (Figure 2.2) is to, obviously, work with files. Using the  
options on this menu, you create new files, open existing 
ones, save files in a variety of formats, display information 
about a file, print a file, and exit SPSS. The File menu can also 
list recently used data files (Recently Used Data) and other 
recently used files (Recently Used Files), so you can quickly 
return to a previous document.

For example, when it comes time to start working 
with the file named Teacher Scale Results, you would se-
lect Open from the File menu and then select the file name 
from the Open dialog box. You will learn more about this 
process in Lesson 7 (Unit 2).

When it comes time to cut or copy data and paste it 
in another location in the current, or another, data file, you 
will go to the Edit menu. You will also seek out options on 
the Edit menu to search for data or text, replace text, and 
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Figure 2.2. The File menu.

Figure 2.3. The Edit menu.

set SPSS preferences (or default settings). All these activities 
and more are found on the Edit menu shown in Figure 2.3.

For example, if you wanted to find what Mary Jones 
scored on the variable named test 1, you could use the Find 
menu command to search for “Mary Jones” and then read 
across the file to find her score on the variable named test 1.

ThE VIEW anD DaTa MEnUS Here’s a chance to 
customize your SPSS desktop. Using various commands 
on the View menu, you can choose to show or hide tool-
bars, Status Bar, and grid lines in the Data Editor; change 
fonts; and use Value Labels. You can see these commands 
in Figure 2.4.
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Figure 2.4. The View menu.

Tip
perhaps the most valuable SpSS command (which is 

available on many Windows-based applications) is the 

CTRL+Z key combination, which reverses the last data 

entry you made.

For example, if we didn’t want to use labels for vari-
ables or grid lines, we would be sure that these options 
(Value Labels and Grid Lines) were not selected.

Variables and their values are the central element in 
any SPSS analysis, and you need powerful tools to work 
with variables. You have them in SPSS. As you can see in 
Figure  2.5, on the Data menu there are commands that 
allow you to define variable properties, sort cases, merge 

Figure 2.5. The Data menu.
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Figure 2.6. The Transform menu.

lead to almost any statistical analysis technique you 
might want to use. These range from a simple compu-
tation of a mean and standard deviation to time series 
analysis and multiple regression to other very complex 
analyses as well.

For example, if you wanted to determine if there 
is a significant difference between the average rat-
ing that Professor 6 received on a teaching evaluation 
form versus the average rating received by Professor 
4, you could look to the Compare Means option on the 
Analyze menu.

ThE GraPhS, UTILITIES, anD aDD-OnS MEnUS  
Want to see what those numbers really look like? Go to the 
Graphs menu where you can create a bar, line, area, and 
other types of graphs. Graphs make numbers come alive, 
and you should pay special attention to Lessons 16, 17, 
and 18, where we show you how to create, edit, and print 
them. Take a look at Figure 2.8 to see what graph options 
are available. With version 23, you also have the opportu-
nity to use the Chart Builder menu command (where SPSS 
walks you through the creation of a graph) or the Legacy 
Dialogs menu command where the SPSS interface from 
earlier versions is accessible.

For example, if you want to see test scores as a func-
tion of gender, a bar graph (on the Graphs menu) could do 
it quite nicely.

The Utilities menu is where you can find out informa-
tion about variables and files, and you can define and use 

Tip
You can set all kinds of default values through the Edit -> 

Options dialog box. For example, if you always want three 

decimal places for your data entry, then click the Data Tab 

and increase the number of decimal places from 2 to 3.

and aggregate files, and assign weight to cases as you 
see fit.

For example, if we want to sort variables or cases, this 
is the menu you would use and the Sort Cases option is the 
menu that would be selected.

ThE TranSFOrM anD anaLyzE MEnUS There will 
be times when a variable value needs to be transformed or 
converted to another form or another value. That’s where 
the commands on the Transform menu you see in Figure 2.6 
come in handy. On this menu, you will find commands that 
allow you to compute new values, create a set of random val-
ues, recode values, replace missing values, and do more.

For example, using the Compute Variable command 
on the Transform menu, you could easily compute a new 
variable that represents the mean of a set of items.

The analyze menu is the meat-and-potatoes menu! 
As you can see in Figure 2.7, there are 20 different op-
tions on the Analyze menu (and many submenus) that 
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is information on SPSS Forecasting and SPSS Data Prep-
aration as add-ons.

ThE WInDOW MEnU, hELP MEnU, anD ThE SPSS 
TOOLBar anD STaTUS Bar The Window menu and 
the help menu function much like any other Windows ap-
plication menus. The Window menu helps you switch from 

sets of variables. You can see these options in Figure 2.9 on 
the Utilities menu.

For example, the Variables option tells us the specif-
ics about each variable, including the name, label type, 
and more.

Add-ons is a kind of catchall menu for commands 
that do not conveniently fit elsewhere. For example, there  

Figure 2.7. The Analyze menu.

Figure 2.8. The Graphs menu.
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